The Raptor Pit: WICD unable to optain IP address - The Raptor Pit

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic
WICD unable to optain IP address

#1 User is offline   DarkoOfTheDark 

  • Looker
  • Group: Members
  • Posts: 1
  • Joined: 23-March 13
  • Gender:Male
  • Location:Canada

Posted 23 March 2013 - 01:38 PM

Using Backtrack 5 R3, I tried connecting to my home wireless network. It's encrypted with a 64 bits WEP key (hexadecimal) - yes I know it's not very safe - but I can't get an IP address.

At first I tried setting a static IP, but then the error was "unable to contact wireless access point".

Then I tried connecting via the command line using iwconfig and dhclient. Still no success.

Then I tried downloading the latest drivers (stable and experimental - I tried both) from Linux Wireless for my network card, but I still get the same results.

Then I tried removing WICD and installing Network Manager for KDE instead; still no IP address.

Finally I tried dpkg-reconfigure wicd, but it didn't change anything.

The laptop is an Acer Aspire 6530-5959, the wireless network chipset is Atheros 9000 series, and my router is a NETGEAR WNR100v2.

#2 User is offline   dostov 

  • Competition Specialist
  • Group: Moderators
  • Posts: 3,039
  • Joined: 07-September 08
  • Gender:Male
  • Location:Bogota, Colombia

Posted 25 March 2013 - 02:11 PM

Network card not compatible with Linux? There's a handful of 9000-series chips, maybe the one you have is not compatible with the current drivers, and/or build.
Posted Image

Posted Image

#3 User is offline   terry1966 

  • Tweaked Geek
  • Group: Members
  • Posts: 601
  • Joined: 03-August 06
  • Gender:Male
  • Location:uk

Posted 25 March 2013 - 05:05 PM

first thing i always try is to connect without any encryption, just use an open network with ssd broadcast.

cpu:- core i7 920
motherboard:- gigabyte EX58-UD3R
memory:- Corsair 6GB DDR3 Dominator PC3-12800C8 1600MHz
gpu:- asus gtx275
hard drives:- ocz 60gb agility ssd, 2xWestern Digital Caviar Black 1TB SATA-II 32MB Cache
power supply:- PC Power & Cooling Silencer 750 Quad
case:- Coolermaster ATCS 840
watercooled cpu.

Share this topic:

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users